RTV Tools

Friday, March 6, 2015

Recording a Scene Animation to convert to a Viewpoint Animation in Navisworks

You probably know that you can import a Viewpoint animation into a Scene animation in Navisworks, like this:
  1. Animation Ribbon - Animator
  2. Add Scene
  3. Right click on the Scene, Add Camera, From Current Viewpoint Animation

Ok, that's fine. But what if you do some work on the Scene Animation, add keyframes, adjust pacing, and then you want to convert it back into a Viewpoint Animation? Here's how you do it:
  1. Open Animator and get a Scene animation ready to press "Play"
  2. Animation Ribbon - Click the Record button 
  3. Click the Scene name, and the Play button will activate in Animator
  4. Press Play in Animator, and wait for your animation to complete
  5. Press Stop in the Ribbon
  6. Press the Record button again to toggle it "off". Navisworks will now save the Animation into your Saved Viewpoints
  7. Delete any unnecessary Cuts etc

With this tip, you can now convert to and from a Scene and Viewpoint animations as needed. Viewpoint animations are a bit easier to put together, but it might be easier to adjust the pacing in the Animator. Obviously, the Animator has more power and control if you intend to actually animate objects in your scene.

On a related note...
I've come across a bit of a bug in Navisworks 2015 with Viewpoint animations and huge models (like 2gb huge). If you have a Home view with Hide/Required and Materials set, and all your Animation views have those options unticked, then you should be able to flick to your animation without losing your colours, right? Well, in some cases it seems to work, but in others it seems to reset the appearance whenever I switch to the animation, meaning I lose colour overrides.

I tried working around the color issue like this:
  1. Open project
  2. Make a new folder
  3. In the folder make a new animation
  4. Drag all of the views from previous animation to the new one
  5. Collapse the Animation
  6. Switch to a view with Hide/Required and Color applied (ie. Home view)
  7. Click on the new animation name (OK, doesn't seem to reset colours)
  8. Expand and click a view (sometimes works, maybe, but can also fail)
Another workaround is to switch to your coloured Home view, save a 2013 version NWD and work in Navisworks 2013. Sometimes the downgrade bakes the colours into the elements, meaning you don't lose them when you switch to and from the Viewpoint Animation.

No comments:

Post a Comment