RTV Tools

Monday, November 26, 2012

Revit Building Pads, Topography and phases

Basically, if you have one site toposurface, and you cut it with pads in different phases, then an 'outline' around every single pad appears in the creation phase of the toposurface (they affect the topo backwards in time).  It looks ugly ...  Additionally, there will be 'holes' cut in the toposurface for the pads.

I recently handled this by making a Design Option Set for Topography, then for each Stage / Building Option combination, I added the entire site Toposurface.  From here, I could use model groups to transfer pads between the different options / phases, while still retaining their size and position and editability.  It was a pain to set up, but once configured properly (with views etc), it seems to work ok.

The most 'logical' way to configure it would be:
  1. Make a Design Option Set
  2. Make an Option called 'Existing'.  Add your original / untouched site topography here.
  3. Duplicate the Option, call it Stage 1.
  4. Make all the Stage 1 pads, then group them.
  5. Duplicate Stage 1 topography option, call it stage 2 (the grouped pads will come through).  Add additional pads in Stage 2 option, then group Stage 2 pads and the Stage 1 pad group (forming a nested group.)
  6. Rinse and repeat
I never said being a Revit pro would be easy.

You can read about the problem at:
Re: Building pads don't seem to respect phases. - Autodesk Discussion Groups


  1. Greatest post ever !!!! Appreciate it!!!

  2. This does not work for me.. I made 2 options within the Main model, named it existing and phase 1, when I try to mode the toposurface together with the pad to the "existing" option Revit says that "building pad can not be added to an option".
    I tried to use the Phases before... I extend the building bad in the further stages and need to view different phases for the mass calculation. In the Phase 0 my building pad does not cut the toposurface, even though all the phases match as indicated in this post