RTV Tools

Monday, July 6, 2009

SECSplashWnd error - Revit 2010 stalls on loading

I logged this error with Autodesk Support:
"...Sometimes Revit 2010 x64 running on my Vista 64 bit machine will not load at all - the program stalls with 'SecSplashWnd' showing in the taskbar..."



And they replied with the following:
"...There are similar issues logged with the support team.A damaged Microsoft .NET Framework can cause this error. Updating to the latest version of .NET won't remove the damaged version from the system.
Please make sure that you are installing the program when you are logged in as the local administrator of the machine, and that all the other programs are closed, including antivirus, firewall, etc.
1. Download and save the .NET Framework 3.5 installers from the following link:
http://www.microsoft.com/downloads/details.aspx?FamilyID=6c095bba-6100-4ec9-9c54-6450b0212565&DisplayLang=en
2. Download and save the .NET Framework 3.5 Service Pack 1 installer from the following link:http://www.microsoft.com/downloads/details.aspx?familyid=AB99342F-5D1A-413D-8319-81DA479AB0D7&displaylang=enPLEASE NOTE: the next two steps will remove ALL instances of the .NET Framework from your system. If you are using any software encryption or logon technologies that require the .NET Framework to operate, they will not operate until you have installed another instance of the .NET Framework.
3. Download and run the .NET Framework cleanup utility from the following link. Select all versions and click Cleanup Now.
http://astebner.sts.winisp.net/Tools/dotnetfx_cleanup_tool.zip
4. Install .NET Framework and the Service Pack that you previously downloaded.
5. Restart your system.
6. Once the system has restarted, repair Revit using Add or Remove Programs.Once you've updated the .NET Framework and repaired AutoCAD, try launching the application.
I recommend that you uninstall and reinstall .Net in Windows safe mode:
http://usa.autodesk.com/getdoc/id=TS75218 Clean installation on Windows® XP..." (bold mine)

As you can see, .NET needs to be fixed to correct this error. I haven't yet attempted this fix, as the problem goes away for me after a reboot - if it continues to be a problem, I will have a go at the steps described.

Let me know if this helped you.

NOTE: The .NET Cleanup Tool link doesn't appear to work - go to this site to find it.

2 comments:

  1. how about in window vista? i had a same problem, just like that.on the startup always show up the 'SecSplashWnd' in the task bar then nothing happen just freeze

    ReplyDelete
  2. With Vista I have noticed that if you don't have Service pack 1 of Vista installed it wont load Revit at all. The minute you install the service pack it works.

    ReplyDelete